Dchp error

Discus and support Dchp error in XBoX on Consoles to solve the problem; Keep getting a dchp error on my X1 when testing connection. I'm using a tp link plug and it was working fine til today. Now all of a sudden it won't... Discussion in 'XBoX on Consoles' started by jclifford101, Jan 3, 2014.

  1. jclifford101
    jclifford101 Guest

    Dchp error


    Keep getting a dchp error on my X1 when testing connection. I'm using a tp link plug and it was working fine til today. Now all of a sudden it won't work it all. When I unplug it I can get my home wifi and sign into live ok but it's only one bar and not
    suitable for playing online. Any help would be greatly appreciated.

    :)
     
    jclifford101, Jan 3, 2014
    #1
  2. My xbox cant connect to the DCHP server

    yeah it sees it and connects to it but it gives me a dchp server error message
     
    SomtooAkaigwe, Jan 3, 2014
    #2
  3. SniprUK
    SniprUK Guest
    "Use your mac to connect your console to Xbox Live" Trouble shoot.

    Hi InfernalTruth, it seems here that your Airport is using a DCHP connection and your Xbox wants to use a static ip. Can you check your Airport settings and tell me if it is using DCHP or static.

    Thanks,

    HeKtiC x Will
     
    SniprUK, Jan 3, 2014
    #3
  4. Diskonekted
    Diskonekted Guest

    Dchp error

    Hey Clifford,

    Sorry to hear it's not working; I've not tried the LAN connection on mine, but it seems that quite a few people are having problems. What kind of error message do you get?

    Also, have you seen the troubleshooting guide
    here
    ?
     
    Diskonekted, Jan 4, 2014
    #4
  5. jclifford101
    jclifford101 Guest
    It says cannot connect to your dhcp server. I checked through my router and the router recognises that the xbox is connected to it and it's also not filtering out the consoles MAC address. It was working fine until last night.
     
    jclifford101, Jan 4, 2014
    #5
  6. Saybur1
    Saybur1 Guest
    I'm having this same problem now. It had been working fine until a few days ago, I didn't change anything before it stopped working. I've tried seemingly everything but it will not connect.
     
    Saybur1, Apr 18, 2014
    #6
  7. Severian2008
    Severian2008 Guest
    I am also having this problem now. Previously it was working fine but now it "Can't connect to your DCHP server". I have tried everything on the troubleshooter (including restarting everything multiple times) and no joy.

    Weirdly I can get it to connect to my iPhone if I turn that into a hotspot.
     
    Severian2008, Apr 18, 2014
    #7
  8. jmcode
    jmcode Guest

    Dchp error

    I have this problem occasionally and am convinced it is a bug in the Xbox One networking code. None of my many other devices have a problem and, when this happens, it does not seem from my router logs that the Xbox One even tries to request a DHCP IP.
     
    jmcode, Apr 18, 2014
    #8
  9. Severian2008
    Severian2008 Guest
    I thought it might be because I have lots of devices on the same wifi so I switched them all off to remove interference and overload. Didn't make any difference. I have tried restarting everything countless times. I am really fed up now. I should have bought
    a PS4.
     
    Severian2008, Apr 18, 2014
    #9
  10. ian2726
    ian2726 Guest
    Same here.

    It'll jump on and off. And say dhcp error.
     
    ian2726, Apr 19, 2014
    #10
  11. Baybutt
    Baybutt Guest
    You guys might want to try clearing all your DHCP leases , this all could be resolved with static IP addresses also
     
    Baybutt, Apr 24, 2014
    #11
  12. jmcode
    jmcode Guest
    Actually, no it can't. When the Xbox One gets itself into this state where it can't connect to the router's DHCP server (which is working fine for all other devices), it is difficult to get it out. A lot of the time, if you try to set a static IP, it won't
    take and will instantly revert to the default 169.x.x.x private IP. One time for me it decided to use the gateway IP as its IP, instead of the one I had just assigned. Currently, while messing around with it just to report to this thread, it won't let me
    save after assigning a static IP. The error? Can't connect to DHCP server.. Obviously, it shouldn't even try to connect to a DHCP server with a static IP set (and from what I can tell it doesn't but reports an error anyway). This definitely appears to
    be a software bug involving the way the Xbox One is saving or recalling network settings and initializing network interfaces, and it particularly manifests itself when the user switches between the wired/wireless interface or connects to a new wireless SSID.
     
    jmcode, Apr 26, 2014
    #12
  13. Baybutt
    Baybutt Guest

    Dchp error

    You could try temporarily hooking it to a CAT5 and see if that forces the ip tables to correct itself. I believe the wireless card powers down when directly connected.
     
    Baybutt, Apr 27, 2014
    #13
  14. taidara
    taidara Guest
    @GZA - Are you able to reproduce this with DHCP reservation?
     
    taidara, Apr 27, 2014
    #14
  15. jmcode
    jmcode Guest
    taidara, yes. I use DHCP reservation for the Xbox One, and the problem persists. Generally, but not always on the first try or without restart, the Xbox One can get a DHCP IP when wired or wireless 2.4Ghz. It worked for a long time on wireless 5.8Ghz (my
    preference), but now it consistently reports "Can't connect to DHCP server" and gives the same error even when manually assigning an IP in Advanced Settings (even though DHCP should not matter when manually assigning). There is definitely something weird
    going on in the Xbox One network settings.
     
    jmcode, Apr 27, 2014
    #15
Thema:

Dchp error

Loading...
  1. Dchp error - Similar Threads - Dchp error

  2. Cant download Sea of thieves error 0x80080206

    in XBoX Games and Apps
    Cant download Sea of thieves error 0x80080206: Hello i cant download Sea of thieves. Download stops at 4mb and does not continue. The error is repeated every time. 58d1362d-ec45-4e77-9dfb-9d33eb78e25e
  3. I have a error with recording clips on the xbox series s it says recording failed 0x82323023

    in XBoX Rewards & Social
    I have a error with recording clips on the xbox series s it says recording failed 0x82323023: So i have tryed almost anything i found and could think of but it still does bot let me screenrecord or anything i can do screen shots but not screenrecordings it says error 0x82323023 can someone...
  4. Why cant I connect to DCHP server on Xbox One?

    in XBoX on Consoles
    Why cant I connect to DCHP server on Xbox One?: My elite Xbox One console cant connect to the DCHP server. Ive tried multiple times to and still cant connect. I did a factory reset and still cant connect. Anyone have a solution?...
  5. Can’t connect to DCHP server

    in XBoX on Consoles
    Can’t connect to DCHP server: Ive been trying to fix this issue for a few days now and nothing seems to work. I use wired connection from a TP link wifi range extender and I keep getting the same message on my Xbox saying that...
  6. : Dchp

    in XboX Networking Hardware
    : Dchp: : Dchp This is a local issue. Check your router as a first point. Try sticking a manual IP in on the same range and with same DNS servers (or use Googles). that will get you up and running in...
  7. Farmers Telecommunications Cooperative: Xbox gives DCHP error with ethernet cable

    in XboX Networking Hardware
    Farmers Telecommunications Cooperative: Xbox gives DCHP error with ethernet cable: Farmers Telecommunications Cooperative (ISPs): Xbox gives DCHP error with ethernet cable Hey there, Thanks for reaching out. I'm sorry to hear about the issue with the console's network...
  8. Can't connect to your DCHP server

    in XboX Networking Hardware
    Can't connect to your DCHP server: Can't connect to your DCHP server I can't connect my wifi to my Xbox but it's fine for all other devices I've tried many times and it has been going on for 11 hours so far. It just keeps coming up...
  9. Dchp not working

    in XboX Networking Hardware
    Dchp not working: Dchp not working Can't connect to dchp something about my mac address being filtered 8cfc5b3f-217a-4187-8265-74211cf4f43c
  10. My xbox cant connect to the DCHP server

    in XBoX on Consoles
    My xbox cant connect to the DCHP server: for the past 6 days it hasnt connected. Ive tried restarting my xbox and modem i tried to factory reset now im stuck in the setup process because it has to be connected to internet. ip:...